Back to overview
Downtime
QA Agents Service Down
May 28, 2026 at 7:23pm UTC
Affected services
QA Agents
Resolved
Jun 2, 2026 at 9:25pm UTC
Agents are functioning as normal again
Affected services
Updated
Jun 2, 2026 at 8:57pm UTC
We are experiencing issues
Affected services
Updated
May 28, 2026 at 9:11pm UTC
The issue with OpenAI is resolved, all agents are functioning normally.
Affected services
Updated
May 28, 2026 at 8:21pm UTC
OpenAI has identified the issue and is doing a rollback. We're investigating switching to other models to minimize downtime.
Affected services
Created
May 28, 2026 at 7:23pm UTC
Ito depends on Azure as a provider through OpenRouter. This service is currently unavailable preventing Ito agents from running.
Affected services